Tags

Saturday, February 14, 2009

[fixed] Downgrading glibc is not supported and a sure way to destruction

Problem:
glibc fails to compile on Gentoo Linux

Error message:
* Messages for package sys-libs/glibc-2.8_p20080602-r1:

* Sanity check to keep you from breaking your system:
* Downgrading glibc is not supported and a sure way to destruction
*
* ERROR: sys-libs/glibc-2.8_p20080602-r1 failed.
* Call stack:
* ebuild.sh, line 49: Called pkg_setup
* glibc-2.8_p20080602-r1.ebuild, line 228: Called die
* The specific snippet of code:
* die "aborting to save your system"
* The die message:
* aborting to save your system
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/sys-libs/glibc-2.8_p20080602-r1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/sys-libs/glibc-2.8_p20080602-r1/temp/die.env'.
*

Problem cause:

Most likely you compiled glibc originally with ACCEPT_KEYWORDS set to "~amd64" or your architecture specific keyword and then while updating or recompilation you did not set ACCEPT_KEYWORDS again.

Fix:
export ACCEPT_KEYWORDS="~amd64"

2 comments:

rikardo150 said...
This comment has been removed by the author.
Anonymous said...

Thank you! This helped me a lot, Im installing gentoo on my notebook and I was having some troubles with emerge